Back to overview
[didi_food] Service recovered
Apr 20, 2026 at 10:30pm UTC
Affected services
DiDi Food
Resolved
Apr 20, 2026 at 10:30pm UTC
Service back to normal
Affected services
Resolved
Apr 20, 2026 at 10:30pm UTC
Service back to normal
Affected services